Rokit 5 G3 Limiter and Stand-by/Mute removal

Finally I got around to figuring this out. Had to poke around a little bit.

Ran across this schematic in the land of diy forums. It’s for the G2 Rokit 6 amps, which had the notorious black goo of death problem, so totally different design (well, probably not that different… these budget companies never really redesign their stuff if they don’t have to, unless they can make it simpler/stupider), but it struck me that their limiter was using just one bipolar transistor right after the input buffer, so I went looking for lone transistors near the input, and lo and behold, there is only one (Q5, just above the right-most large ceramic capacitor).

IMG_0273

Oscilloscope revealed bits of signal being leached off, so it seemed I had found the culprit. Removed Q5, but both amplifiers suddenly muted… hm.

Traced signal from top-most pin of Q5, found it running to the ‘mystery chip’ just above, U5. Looks like it’s some kind of gate circuit: when it receives enough input voltage at pin 5 (lower left pin), seems like it opens pin 4 (upper left) and passes 5V, which is what the amp circuits need to unmute and shut off standby (datasheet for TDA7296 actually specifies 3.5V minimum to disengage mute/standby function).

This reveals a couple of things about KRK’s design. First off, the limiter is running all the time. Even at relatively low levels it seems to be leaching signal, and globally for both treble and bass. Secondly, the mute circuit depends on the output of the limiter in order to engage, so the limiter needs to be operating rather aggressively in order to unmute the amplifiers. This is why, when I removed Q5, the mute circuit wasn’t seeing any input. I’ll say again: IF YOU HEAR ANY SOUND, THE LIMITER IS LIMITING, A LOT. 🤦‍♂️

So… remove the transistor (hot air is easiest), remove the IC, and short pins 3 and 4 as shown (I used a little piece of wire clipping).

KRK mod detail

Now the amp engages immediately, without any lag. There are electrolytic caps decoupling the input to the mute/standby pins in the amplifier, so there won’t be a big pop. Can see the voltage at pins 9/10 of TDA7296 rising and falling gently with on/off.

Things sound ‘snappier’, more precise––these are some real speakers now! This project has officially reached it’s zenith. EDIT: I’m shitting my pants at how amazing this sounds. All my previous mods really seem to have come to life now, the low end is incredibly clear and integrated (it’s like all the overtones just lock), I find I’m listening with the volume a bit lower, and both speakers sound more balanced (the right speaker always felt just a little softer, and they’re ‘matched’). My reference recordings sound uncanny. And just over a little transistor…

*PROCEED AT YER OWN RISK* I listen primarily to Classical stuff, I’m not pounding EDM or anything. I assume this circuit is here for a reason.

If you want someone to do this for you, check out this guy: https://www.danieldialatone.com/gallery. Used to be a head engineer for Black Lion Audio, studio monitor ‘enhancements’ are his specialty. I just use the TI SoundPlus series of opamps (which I think sound great, enough of an improvement), based on their functional equivalency to what’s on the board (FET/bipolar, comparing input impedance, etc) he actually hand selects different opamps for their unique flavor. If my amateurish experimentation got me this far, just think what a real pro can do!

Coming up: RME UFX mods, Presonus DP88 mods, Behringer ADA8200 (re-)mods, Yamaha TG77 mods

10 thoughts on “Rokit 5 G3 Limiter and Stand-by/Mute removal”

  1. Legendary work just got rid of the auto standby on my set thanks to you.
    Was driving me mad not been able to listen to things quietly without em turning off.

    Like

    1. Glad it helped! Just be sure to shut them off periodically. The heat sinks do get hot when the amplifiers are always on, and I actually just had one of mine go into thermal shut down (160˚C!) the other day while I was using them as monitors in a slightly-warmer-than-comfortable theater.

      But I am really, really glad that when I switch them on, they’re ready to go… Cheers!

      Like

  2. Hi! I just found your great mod and tried it. But I have no sound at all. The monitor switches on but no sound at all. I am talking about a Rokit 4 g3. But it has the same pcb and same components.
    I took of both, transistor and ic and shortened pin 3-4.
    Is there anything else you modified maybe?

    Thanks a lot in advance!

    Like

    1. Ugh, bummer, I’m sorry to hear that… modding is always a fickle thing. I’ve often created a few mysteries for myself, which were later revealed to be small oversights.

      Basically what needs to happen is pin 9 of the TDAxxxx amplifier chips (same for HF and LF? I can’t remember…) needs ~5VDC to prevent standby. The unmarked chip I say to remove is a gate of some kind, and I think I traced one of those pins (3 or 4, I can’t remember) to the circuitry feeding pin 9. If you have a multimeter, see if you can probe pin 9 on the amplifier chip to see if it’s getting 5 volts, then work your way back. In any case, you don’t *need* 5 volts from those pins, you can get it from someplace else, but you might need to poke around.

      Be careful! There’s a lot of voltage on that board…

      Just FYI, see p.2 and bottom of p.3: https://www.st.com/resource/en/datasheet/tda7294.pdf

      Like

  3. So I somehow succeeded. I took the 5V from the jumper beside the relais – connector and connected it to pin 5 of the TDA.
    But the strange thing is sometimes it is switching the amp on and sometimes it won’t.
    If yes, everything is fine and it works and stays on.
    If it does not then it’s just dead, no sound, although the rest is on.
    I must admit that I am not good in electronics although I am good in soldering…
    ok now I outed myself.

    Best from Berlin

    Like

      1. I think it has to do with the 5V. Switching on and of 2, 3 times activates it. Maybe the 5V is not stable enough?
        So far I only started with one speaker. I’m gonna use them for Talkback- Monitor, which is maybe a dumb idea… 😂
        But what I can say right away is, if it’s working the monitor sound much more open and dynamically more precise.
        I will try out a different 5V source tomorrow.
        Btw: what part of the circuit opens the preamp- audio path? Could it be that this is the problem? On pin 1 of the IC I have 5 V… wa s it the same in your monitor? Maybe the short should be somewhere else?

        Like

      2. Yeah, actually, now that you mention it, I don’t think there’s any kind of regulator for 5V, seems to be achieved with voltage divider. I have been planning to dig into my pair again to change a couple capacitor sizes and add some extra film bypass caps I overlooked, so I’ll revisit the limiter/mute function again.

        Today I finished up a mod on a Presonus HP amp, and one of the channels simply refused to work. There was the *tiniest* solder bridge shorting one of the inputs to ground, I couldn’t see it, but I reworked a bunch of pins and, voila, it works. They don’t call it a voided warranty for nothing…

        Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s